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1 Log on 
 

 
Figure 1 

 

On launching the “ProMaSo” software, you will get a log on screen as shown in Figure 1. After entering the 

“Name” and “Password” click on logon to start the application. 

 

As “ProMaSo” stores all configuration data in a database per User, you need to log on. Through sessions, 

“ProMaSo” stores each users screen layout and selected modules. 

 

On logging in, you can also select the language used by the software. Following languages are available: 

 nl-NL  Dutch 

 en-US  English 

 de-DE German 

 fr-FR French 

After logging in with the correct user name and password, you will enter the main screen. 
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2 Main user interface 

2.1 Ribbon bar 
 

The ProMaSo user interface is based on the ribbon bar. 

 

The three parts of the Ribbon are tabs, groups, and commands. 

There are three basic components to the Ribbon. It's good to know what each one is called so that you 

understand how to use it. 

 Tabs. There are seven basic ones across the top. Each represents an activity area. 

 Groups. Each tab has several groups that show related items together. 

 Commands. A command is a button, a box to enter information, or a menu. 

Everything on a tab has been carefully selected according to user activities. For example, the Insert tab contains 

all the things you need to generate a report. 

 

Quick Access Toolbar 

The Quick Access Toolbar is the small area to the upper left of the Ribbon. It contains some commands that you 

use over and over every day. 

 

The ProMaSo Button  . 
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Click this button, in the upper-left corner of the program window, to get the basic commands to open, save, and 

print your reports. 

 

 

2.2 Create reports 
 

 

The ProMaSo user interface provides you with a clear and organized  tools when you need  them. 

 

 Save time and take advantage of the powerful capabilities by selecting from the predefined reports. 

  When you apply your report, you can choose the machine from the gallery.  
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In ProMaSo you can  create a report to the following formats. 

 

 PDF (Portable Document Format) PDF is an electronic file with a fixed layout, so you can share the file. 

In PDF format, a file can be viewed online or printed. Moreover, the data in the file cannot be easily 

changed. 

  XLSX (Excel Document Format) Excel is software that allows you to create tables, and can calculate 

and analyze data. Such software is called spreadsheet software. With Excel you can create own tables 

based on the data of the reports. 

3 Insert a report 
 

On the Ribbon, click the Insert tab. This will give you quick access to insert a predefined report. 

3.1 Recipe Group 
 

On the Ribbon, click the Insert tab, and in the Recipe group  you have quick access to all reports related to items.  

3.1.1 Counter 

 

On the Ribbon, click the Insert tab, and in the Recipe group, click Counter and from the Gallery select the 

equipment. 

 

The recipe counter shows the quantity produced. 
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3.1.2 States 

 

On the Ribbon, click the Insert tab, and in the Recipe group, click States and from the Gallery select the equipment. 

 

Recipe States report shows the states for each item produced.  

An item can have the following states: Start, Pause, Resume, Complete or Abort 

 

 START is the state when the equipment begins executing its process on a product  

 PAUSE is the state when the process execution on an item has been paused. 

 RESUME is the state when the process work on an item has been restarted. 

 COMPLETE is the state when the process work on an item is  

 ABORT is the state when the process work that has been paused on an item is aborted. 
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3.1.3 Items 

 

On the Ribbon, click the Insert tab, and in the Recipe group, click Items and from the Gallery select the equipment. 

 

A Recipe Item report shows the items produced with their estimated  and  real times. 

 

 DURATION of the process from start to complete/abort including the pause/resume durations. 

 OVERALL DURATION of the process from complete/abort of the previous item to complete/abort 

including the pause/resume durations. 

 ATTENDED duration of the Process from start to complete/abort not including the pause/resume 

durations. This attended duration can be compared with the estimated time. 
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 ESTIMATED duration of the process from start to complete/abort. This estimated duration is calculated 

by the pre-processor. 

 OVERALL ESTIMATED duration of the process from complete/abort of the previous item to 

complete/abort. It includes the process exchange time of the items. This overall estimated duration is 

calculated by the pre-processor. 

 

 

3.1.4 Items All 

 

On the Ribbon, click the Insert tab, and in the Recipe group, click Items All. 

 

Recipe items all report shows all items produced on all equipments with their estimated and real times.  

 

 DURATION of the process from start to complete/abort including the pause/resume durations. 

 OVERALL DURATION of the process from complete/abort of the previous item to complete/abort 

including the pause/resume durations. 
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 ATTENDED duration of the Process from start to complete/abort not including the pause/resume 

durations. This attended duration can be compared with the estimated time. 

 ESTIMATED duration of the process from start to complete/abort. This estimated duration is calculated 

by the pre-processor. 

 OVERALL ESTIMATED duration of the process from complete/abort of the previous item to 

complete/abort. It includes the process exchange time of the items. This overall estimated duration is 

calculated by the pre-processor. 

 

 

 

 

3.2 Recipe Part Group 
 

On the Ribbon, click the Insert tab, and in the Recipe Part group  you have quick access to all reports related to the 

parts in a item.  

3.2.1 Parts 
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On the Ribbon, click the Insert tab, and in the Recipe Part group, click Parts and from the Gallery select the 

equipment. 

 

Recipe parts report shows for each item the parts produced with their estimated and  real times.. 

 

 DURATION of the process from start to complete/abort including the pause/resume durations. 

 OVERALL DURATION of the process from complete/abort of the previous item to complete/abort 

including the pause/resume durations. 

 ATTENDED duration of the Process from start to complete/abort not including the pause/resume 

durations. This attended duration can be compared with the estimated time. 

 ESTIMATED duration of the process from start to complete/abort. This estimated duration is calculated 

by the pre-processor. 

 OVERALL ESTIMATED duration of the process from complete/abort of the previous item to 

complete/abort. It includes the process exchange time of the items. This overall estimated duration is 

calculated by the pre-processor. 

 BASE ESTIMATED duration of the process from start to complete/abort if only one part must be 

produced (not nested). 
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3.2.2 Parts All 

 

On the Ribbon, click the Insert tab, and in the Recipe Part group, click Parts All. 

 

Recipe parts all report shows for each item the parts produced on all equipment with their estimated and  real 

times. 

 

 DURATION of the process from start to complete/abort including the pause/resume durations. 

 OVERALL DURATION of the process from complete/abort of the previous item to complete/abort 

including the pause/resume durations. 

 ATTENDED duration of the Process from start to complete/abort not including the pause/resume 

durations. This attended duration can be compared with the estimated time. 

 ESTIMATED duration of the process from start to complete/abort. This estimated duration is calculated 

by the pre-processor. 
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 OVERALL ESTIMATED duration of the process from complete/abort of the previous item to 

complete/abort. It includes the process exchange time of the items. This overall estimated duration is 

calculated by the pre-processor. 

 BASE ESTIMATED duration of the process from start to complete/abort if only one part must be 

produced (not nested). 

 

 
 

 

3.3 Recipe Measurements Group 
 

On the Ribbon, click the Insert tab, and in the Recipe Measurements group you have quick access to all reports 

related to the measurements of an item.  

3.3.1 Measurements 
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On the Ribbon, click the Insert tab, and in the Recipe Measurements group, click Measurements and from the 

Gallery select the equipment. 

 

Recipe measurements report shows the measurements of the items produced. 

 

 Each parameters has its own Y axis based on the minimum and maximum value of the parameter.  

 

 

 

3.4 Equipment State Charts Group 
 

On the Ribbon, click the Insert tab, and in the Equipment State Charts group you have quick access to all reports 

related to the equipment states.  

3.4.1 Overall Equipment Effectiveness 
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On the Ribbon, click the Insert tab, and in the Equipment State Charts group, click OEE and from the Gallery select 

the equipment. 

 

The OEE Industry Standard aims to give guidelines how to define OEE in order to find ALL potential losses in 

effectiveness. OEE begins with Planned Production Time and scrutinizes efficiency and productivity losses that 

occur, with the goal of reducing or eliminating these losses. There are three general categories of loss to 

consider - Down Time Loss, Speed Loss and Quality Loss. 

 

OEE = Availability * Performance * Quality 

 

 AVAILABILITY takes into account Down Time Loss, which includes any Events that stop planned 

production for an appreciable length of time. 

 PERFORMANCE takes into account Speed Loss, which includes any factors that cause the process to 

operate at less than the maximum possible speed, when running 

 QUALITY takes into account Quality Loss, which accounts for produced pieces that do not meet quality 

standards, including pieces that require rework. 
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3.4.2 Pareto 

 

On the Ribbon, click the Insert tab, and in the Equipment State Charts group, click Pareto and from the Gallery 

select the equipment. 

 

A Pareto analysis assumes that 80% of the problems caused by only 20% of the situation. 

 

 
 

3.4.3 State Pie 

 

On the Ribbon, click the Insert tab, and in the Equipment State Charts group, click State Pie and from the Gallery 

select the equipment. 

 

Pie charts display the contribution of each value to a total. 

 

 OFF means that a piece of equipment has been powered down and is not available for production. 
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 DOWN means that a piece of equipment cannot produce items either due to a lack of components or 

other consumable material, an equipment malfunction, host or operator intervention. 

 SETUP means that a piece of equipment is being configured. Set-up involves a deliberate action being 

taken on the equipment. 

 READY-IDLE-STARVED is the state when the equipment is empty and it can’t pull any items in to 

work on. 

 READY-IDLE-BLOCKED is the state when the equipment is full and it can’t push any items out. 

 READY-PROCESSING-ACTIVE is the state when an item is available but no recipe is being executed. 

This includes time intervals when items are transferring into a piece of equipment. 

 READY-PROCESSING-EXECUTING is the state in which the equipment is executing a recipe 

 

 
 

 

3.4.4 State Column 
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On the Ribbon, click the Insert tab, and in the Equipment State Charts group, click State Column and from the 

Gallery select the equipment. 

 

Column charts are used to compare values across categories. 

 

 OFF means that a piece of equipment has been powered down and is not available for production. 

 DOWN means that a piece of equipment cannot produce items either due to a lack of components or 

other consumable material, an equipment malfunction, host or operator intervention. 

 SETUP means that a piece of equipment is being configured. Set-up involves a deliberate action being 

taken on the equipment. 

 READY-IDLE-STARVED is the state when the equipment is empty and it can’t pull any items in to 

work on. 

 READY-IDLE-BLOCKED is the state when the equipment is full and it can’t push any items out. 

 READY-PROCESSING-ACTIVE is the state when an item is available but no recipe is being executed. 

This includes time intervals when items are transferring into a piece of equipment. 

 READY-PROCESSING-EXECUTING is the state in which the equipment is executing a recipe 
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3.5 Equipment Overview Charts Group 
 

On the Ribbon, click the Insert tab, and in the Equipment Overview Charts group you have quick access to all 

reports related to the equipment.  

3.5.1 State All 

 

On the Ribbon, click the Insert tab, and in the Equipment Overview Charts group, click State All. 

 

State all report shows the equipment states of all equipments. 

 

 OFF means that a piece of equipment has been powered down and is not available for production. 

 DOWN means that a piece of equipment cannot produce items either due to a lack of components or 

other consumable material, an equipment malfunction, host or operator intervention. 
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 SETUP means that a piece of equipment is being configured. Set-up involves a deliberate action being 

taken on the equipment. 

 READY-IDLE-STARVED is the state when the equipment is empty and it can’t pull any items in to 

work on. 

 READY-IDLE-BLOCKED is the state when the equipment is full and it can’t push any items out. 

 READY-PROCESSING-ACTIVE is the state when an item is available but no recipe is being executed. 

This includes time intervals when items are transferring into a piece of equipment. 

 READY-PROCESSING-EXECUTING is the state in which the equipment is executing a recipe 

 

 

 
 

3.5.2 State Runtime 

 

On the Ribbon, click the Insert tab, and in the Equipment Overview Charts group, click State Runtime. 
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State Runtime report shows the state in real time of the selected equipment. After selecting all machines you 

want to view, the chart will be filled with the last statuses. The initial time is 15 minutes, and the chart will 

update every machine. The chart is updated every minute.  

 

 OFF means that a piece of equipment has been powered down and is not available for production. 

 DOWN means that a piece of equipment cannot produce items either due to a lack of components or 

other consumable material, an equipment malfunction, host or operator intervention. 

 SETUP means that a piece of equipment is being configured. Set-up involves a deliberate action being 

taken on the equipment. 

 READY-IDLE-STARVED is the state when the equipment is empty and it can’t pull any items in to 

work on. 

 READY-IDLE-BLOCKED is the state when the equipment is full and it can’t push any items out. 

 READY-PROCESSING-ACTIVE is the state when an item is available but no recipe is being executed. 

This includes time intervals when items are transferring into a piece of equipment. 

 READY-PROCESSING-EXECUTING is the state in which the equipment is executing a recipe 
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4 Data Filtering 
 

On the Ribbon, click the Data tab. This will give you quick access to insert a predefined report. 

4.1 Connections 
 

On the Ribbon, click the Data tab, and in the Connections group  you have quick access to all issues related to your 

connections.  

4.1.1 Refresh the reports 

 

On the Ribbon, click the Data tab, and in the Connections group, click Refresh all dropdown button and click on 

Refresh All to refresh all the reports are click Refresh to refresh the report of the current active window 
 

4.1.2 Remove data 

 

On the Ribbon, click the Data tab, and in the Connections group, click Remove Data dropdown button and click 

one of the dropdown items to remove the data older than selected.  

 

This will keep your data compact and improve performance. 

 

4.1.3 Connections 

 

On the Ribbon, click the Data tab, and in the Connections group, click Connections button. The connections dialog 

will appear. Now you can test your database connection. 
 

4.2 Sort and filter 
 

On the Ribbon, click the Data tab, and in the Sort and Filter group you have quick access to all issues related to 

filter the displayed data.  

4.2.1 Filter based on Shift 

 

On the Ribbon, click the Data tab, and in the Sort and Filter group, click Filter Shift dropdown button and click on 

a Shift defined in the dropdown. 
 

A quick access to specify shift as criteria to limit which records are included in the result set of a query. 

4.2.2 Filter based on Day, Week or Month 
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On the Ribbon, click the Data tab, and in the Connections group, click Filter Day, Week or Month button. 

 

A quick access to specify today, this week or this month as criteria to limit which records are included in the 

result set of a query. 

4.2.3 Advanced filtering 

 

On the Ribbon, click the Data tab, and in the Connections group, click Advanced button. 

 

To specify criteria to limit which records are included in the result set of a query. A dialog is shown where you 

can define the start and end data of the filter. 

 

5 Arrange or Switch Between Windows 
 

On the Ribbon, click the View tab. This will give you quick access to arrange your windows. 

5.1 Window 
 

On the Ribbon, click the View tab, and in the Window group you have quick access to arrange your open windows. 

5.1.1 Compare Windows Side By Side 

 

On the Ribbon, click the View tab, and in the Window  group, click Arrange All . 

 

A dialog will appear to tile all open windows side-by-side on the screen. 

 

5.1.2 Save Workspace 

 

On the Ribbon, click the View tab, and in the Window  group, click Save WorkSpace . 

 

 Save the current layout of all windows as a workspace so that it can be restored later. 

5.1.3 Switch Window 

 

On the Ribbon, click the View tab, and in the Window  group, click Switch Window . 

 

Switch to a different currently open window. 
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6 Prepare to use ProMaSo 
 

6.1 Equipment Configuration 

 

Click the ProMaSo button, in the upper-left corner of the program window, and in the left plane select Prepare and 

click Equipment Configuration. 
 

 

 
 

A dialog will show all configured equipment. The user can set the serial number and description of the 

equipment.  
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6.2 Calendars 
 

Click the ProMaSo button, in the upper-left corner of the program window, and in the left plane select Prepare and 

click Calendars. 
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Under the calendars configuration company non working days or holidays can be entered. Also the daily 

working hours are set up. For all calculations, these calendars are taken in account. 

 

6.3 Restrict Permissions 
 

Click the ProMaSo button, in the upper-left corner of the program window, and in the left plane select Prepare and 

click Restrict Permissions. 
 

 

 
 

 

For the administrator of the ProMaSo package it is possible to add users, configure the visible parts of the insert 

tab or hide them. 
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7 Export to Excel or PDF 

7.1 Excel 
 

Click the ProMaSo button, in the upper-left corner of the program window, and in the left plane select Save As and 

click Excel Workbook button. 
 

 

 
 

 

Excel templates are defined for each report. The first sheet of the workbook always contains the data. Most 

templates contain a pivot table and a pivot chart. Users can extend these templates.  
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7.2 PDF 
 

Click the ProMaSo button, in the upper-left corner of the program window, and in the left plane select Save As and 

click Save as PDF button. 
 

 

 

 
 

 

8 External packages 
For the metal sheet production industries a connection with Wicam, and also with TruTops are available.  

ProLaSo also has a module for communication with SAP and different databases. Through this module usage, a 

connection with other systems can be foreseen. For more information feel free to email us at 

info@ProLaSo.com. 

 

9 Continuous development 
 

mailto:info@ProLaSo.com
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As being a ProMaSo user, you can cooperate at a better ProMaSo. Do not hesitate to send us ideas to make the 

software even better suite your needs. You can mail us at info@ProlaSo.com or development@ProLaSo.com 

“Continuous improvement through continuous development” 

The complete ProMaSo team thanks you as user for helping to improve our software! 

 

 

 

 

 

 

mailto:info@ProlaSo.com
mailto:development@ProLaSo.com

